Lost access to volume error with HP Lefthand SAN storage after upgrading to VMware vSphere 4.1 and the fix

We are using a HP Lefthand cluster consisting of 2 P4500 devices with about 8TB usable storage. While testing, our ESX host experienced loss of connection to the Lefthand SAN right after the upgrade to ESXi 4.1. Repeated events occurred in the event log stating that ‘access to the volume was lost’ and ‘successfully restored’ right after.


After some searching I noticed a small note on one of VMware’s HCL pages: 1. Install SAN/iQ 8.5 Patch 10092-00 on the storage array when ESX/ESXi 4.1 server has QLogic hardware iSCSI HBA.

As it happend, we are using QLogic QLA4052C HBA’s and our Lefthands were running SAN/IQ 8.1. Here’s the link to the patch release notes.

Needless to say, we aborted our tests and planned for the SAN upgrade first (we initially planned to do it after the ESX upgrade). We opted to go for SAN/IQ version 9.0 because we wanted to make use of VMware VAAI. Before the SAN upgrade I made sure ALL our QLogic HBA’s had the exact same BIOS and firmware, including our spare parts. 2 Weeks later we upgraded the Lefthand SAN.

There was only one problem with the new SAN/IQ 9.0 software. The Queue Depth Total Performance Monitor values for the cluster are now increasing by their nodes values. The values has become cumulative and is therefor now useless. When we noticed it, however, it didn’t seem to reflect the performance of the SAN at all. Everything was running fine. We checked with HP and confirmed this is a UI bug only. HP confirmed that it will be fixed in a future patch. We decided not to downgrade to SAN/IQ 8.5 because the ‘pros’ outweigh the ‘con’.

After about 3-4 days I started to test the ESXi 4.1 upgrade again. This time we had no problems. 1 Week later we upgraded 1 ESX cluster to ESXi 4.1. The next week we upgraded our second cluster. The upgrade went smooth. We are now using VAAI and are quite happy with the overall performance.

.

Advertisements

About Yuri de Jager
Technology Addict

One Response to Lost access to volume error with HP Lefthand SAN storage after upgrading to VMware vSphere 4.1 and the fix

  1. pinedao says:

    Hello Yuri’s ,

    How to do for display the WMware HCL’s pages ?

    regards

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: